Jump to content

1994 Toyota T100


wildweaselmi
 Share

Recommended Posts

  • Administrators

So I acquired this 1994 Toyota T100 DX Longbed 4x4 with the 3.0L engine and Manual 5spd Trans.  Runs good and it appears to have had the timing belt and water pump replaced and a fresh tune up but it idling high.

Clutch pedal doesn't disengage.  You push the pedal to the floor and it doesn't return to the original position.

The bed is pretty rusty on the outside.  The bed itself seems okay.

Frontend is loose (needs balljoints and possibly idler arm)

Link to comment
Share on other sites

  • Administrators

Had to fix a few things

  • Both CV Axles (purchased from PartsGeek)
  • 555 Balljoints from PartsGeek
  • 555 Idler Arm from PartsGeek
  • Clutch Master & Slave Cylinder from Marlin Crawler
  • ASIN Clutch and a Flywheel from Marlin Crawler

Noticing gas leak around where the gas tank is..  need to check into that

Also want to change the basic gauge cluster to one with a tach from an SR5 model.  Clusters on eBay for anywhere from $140-$220 but you need to know if you have an electronic speedo or cable ran speedo.

Need to bring the truck in the garage and address the gas leak first.  A new Toyota gas tank runs around $700 but I believe I can fix it for less but unfortunately I just filled the sucker up.  Note there was no gas leak until I filled it up so its probably a hole somewhere near the top of the tank.

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.